Hosting Linux y WordPress – como evitar el error “500-Internal Server Error”

La función de actualización automática del conocido Cms WordPress es la de efectuar la sobreescritura de los archivos y volver a configurar los permisos CHMOD según el esquema previsto por los desarrolladores.
Tal configuración, en caso de espacio en Hosting Linux, causa que se manifieste el error "500 - Internal Server Error".

Para solucionar el error es suficiente con aplicar una pequeña modificación (patch) en el archivo "wp-config.php" de WordPress, que permitirá la correcta configuración de los permisos a aplicar a archivos y carpetas después de cada nueva actualización de la aplicación.

Necesitará por eso:

  • Efectuar el download del archivo “wp-config.php" de Word Press, usando un Cliente Ftp (por ejemplo FileZilla);
  • Abrir el archivo "wp-config.php" con un editor de texto (ej. Notepad);
  • En cualquier lugar del archivo añadir las siguientes líneas:

    define('FS_CHMOD_FILE',0755);
    define('FS_CHMOD_DIR',0755);

 

  • Guardar el archivo;
  • Subir el archivo sobrescribiendo el actualmente existente.

Una vez aplicada la modificación descrita será posible efectuar la actualización automática de WordPress sin que se verifiquen problemas debidos a los permisos CHMOD.

ATENCIÓN: tal modificación no es necesaria para los WordPress instalados mediante Applications Installer.
Si tu sitio se encuentra en error “Internal Server Error” efectúa la modificación indicada y luego la Restauración de Permisos por la Herramienta apropiada en el Panel de Control.